cancel
Showing results for 
Search instead for 
Did you mean: 

Client list does not populate during restore on appliance 5230 , 2.6.0.3

Hi ,

What i am doing ::

we are migrating all clients from one master server to appliance . Old backup images and catalog were not required , so i only had to redirect the clients from old master server to appliance . I added appliance to " additional servers " of clients. Then remove them from policy of existing master server . Added them in policy of appliance . Made the appliance as " new master " for clients and remove " current master " from additional server list. It all worked fine . After that i upgraded the client software from appliance using " update_clients " script and it also completed successfully.

Issue ::

I am able to take backup of clients , but when i try to restore the client,  " source and destination " fields only shows the appliance hostname. Help manual says that you can add clients by using " edit client list " button , but there is no such button. I can restore the client by manually entering the " source and destination " . but what is the reason client list is not populating automatically. I did some googling and found the client list populates for all clients which are listed in backup policies. i tested it on VMs and it's true. So now i have clients addedd in my backup policies. so what is the reason list is not displaying all clieants available for restore.

 

looking for some solution.

Thanks in advance

1 Solution

Accepted Solutions
Accepted Solution!

Hi .. I found the solution of

Hi ..

I found the solution of this issue.

If you have installed the netbackup java admin console on your PC and you are using it to connect with a remote master server , then during restore BAR GUI will not populate the list of clients ( if you click browse to change the source or destination machine for restore )

but if X11 forwading is enabled on you master server , and you are using master server's admin console then you will see every client in BAR gui during restore

View solution in original post

11 Replies

Hi,   The list doesn't

Hi,

 

The list doesn't automatically populate with clients. Please post the note that says it does as i would like to see it. Clients appear in the host properties > clients section after being added to the policies, not the source/client destination of the BAR gui.

Hi Riaan , I just read that

Hi Riaan ,

I just read that in some forum but tested on my VMs running 7.5 master server and clients and it works . After each time you add or delete a client from policy just close and open the admin console and changes will be there in BAR GUI.  But at the moment it doen't matter . I just need to know if there is any setting which triggers the client list to populate in BAR GUI.

 

Thank You

Ok, I'll check this on my vm

Ok, I'll check this on my vm and see if it works as you say.

Windows BAR or

Windows BAR or Linux/Unix/Java BAR?

i am using netbackup 7.6

i am using netbackup 7.6 admin java console to connect to appliance from my windows machine.

Ok so I looked at this

Ok so I looked at this quickly. If you look in your jnbSA log (/usr/openv/netbackup/logs/user_ops/nbjlogs/) you'll see that when you click on the "browse" button next to "Source client for restores" it will run the bppclients command to generate the list of clients.

 

In the log you'll see this

[root@ora11g-01 nbjlogs]# tail -f jbp.root.jnbSA.31373.log
    Error Msg:
    Server Locale: en_US.UTF-8
    TO[0]: '/usr/openv/netbackup/bin/admincmd/bpplclients' -allunique -l -M ora11g-01
    FROM[0]: CLIENT app-01 Linux RedHat2.6.18 0 0 0 0 *NULL*
    FROM[1]: CLIENT ora11g-01 Linux Linux 0 0 0 0 *NULL*
    FROM[2]: CLIENT test_host linux linux 0 0 0 0 *NULL*
    FROM[3]: CLIENT test_host1 linux linux 0 0 0 0 *NULL*
    FROM[4]: CLIENT test_host2 linux linux 0 0 0 0 *NULL*
    Aux data: null

 

So have a look in your systems logs and let me know what its doing.

Riaan ,   Thanks for the

Riaan ,

 

Thanks for the update . but i have installed the JAVA console on my windows PC . I am using this console to connect to remote appliance. So is there any way to check its logs

Also i doubt that this java console which is installed on my PC does not show client list because during testing on VMs , i use the x11 forwading to redirect the display of JAVA console installed on UNIX master server , and all clients were listed there.

 

regards

Ali

So if you use X11 and open

So if you use X11 and open the console on the master it works, and if you open using JAVA console it does NOT work?

I am going to test this ..

I am going to test this .. will update you with findings.

Accepted Solution!

Hi .. I found the solution of

Hi ..

I found the solution of this issue.

If you have installed the netbackup java admin console on your PC and you are using it to connect with a remote master server , then during restore BAR GUI will not populate the list of clients ( if you click browse to change the source or destination machine for restore )

but if X11 forwading is enabled on you master server , and you are using master server's admin console then you will see every client in BAR gui during restore

View solution in original post

Try add your machine as a

Try add your machine as a server in the host properties of the master.