cancel
Showing results for 
Search instead for 
Did you mean: 

Status 58 Can't connect to client

I have a Solaris 10 master and media server, a Solaris 10 media server with a C4 library direct connected.  I am trying to do an NDMP backup from a Netapp filer on the same network.  So, this is considered a remote NDMP backup.  When I attempt to do a backup, I get the following in the Admin Console on the master server:

Error bpbrm (pid=21078) cannot connect to filer3, Operation now in progress (150) can't connect to client (58).

There is no bpbrm messages on the master but on the media server, the bpbrm log contains:

job_disconnect: Disconnected

ConnectionCache::connectAndCache: Acquiring new connection for host alabama, query type 1

vnet_pbxConnect: pbxConnectEx Succeeded

logconnections: BPDBM CONNECT FROM 138.109.248.35.43190 TO 138.109.250.180.1556 fd = 5

db_end: Need to collect reply

verify_client: bpbrm.c.34470: start_bpcd_stat failed: 58 58 0x0000003a

bpbrm main: bpbrm.c.2782: verify_client failed: 58 58 0x0000003a

bpbrm kill_child_process: start

OpenMailPipe: /usr/ucb/mail...

bpbrm Exit: client backup EXIT STATUS 58: can't connect to client

 

Any suggestions would be greatly appreciated.

1 Solution

Accepted Solutions
Accepted Solution!

Initially, can you confirm that the Policy is indeed set up as

NDMP & not Standard or MS-Windows-NT?

View solution in original post

5 Replies
Accepted Solution!

Initially, can you confirm that the Policy is indeed set up as

NDMP & not Standard or MS-Windows-NT?

View solution in original post

If all the NMP credentials

If all the NMP credentials and Policy created > type-NDMP The try this: 1. Launch the NetBackup Administration Console, connecting to the master server 2. Expand Host Properties in the left pane 3. Select Master Server in the left pane 4. Click the name of the master server in the right pane 5. Select the Client Attributes section 6. Add the name of the client in question if it isn't listed 7. In the Connect Options tab for the client, make the following changes: BPCD connect back -> "Random port" Ports -> "Reserved port" Daemon connection port -> "Daemon port only"

FW issues !?

Do you have any FW between master, server or cliente? IF so, check for especific NB ports in FW, those must be open in both ways.

Do you have, in client propoeties, the master and media servers inserted in SERVERS TAB?

Hi Andy, Wow, what a quick

Hi Andy,

Wow, what a quick reply.  thank you.  I mistakenly set it back to standard policy after moving the library from a netapp host to a Solaris.  Changed the policy from Standard to NDMP and it's working great!  Thanks, so much and thanks to all for your reply.

ri

ck

Glad it's sorted.

Wasn't too sure. Just looked like the errors you get when the client s/w isn't installed on the client (which obviously it isn't on a filer!). Tried it this end by changing one of ours to Standard & MS-Windows-NT but I got a "57" connection refused (which was why I wasn't too sure).